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InsertMesh & ZSketch: Modeling a Salivary Acinus
Techniques covered: ZSpheres, Custom InsertMesh, Cinema4D 
Soft Bodies OR Move Topological Brush, ZSketch)

Creating Lumen Using ZSpheres
•	Tool > Current Tool > ZSphere
•	Activate Edit Mode
•	Alternate between Draw (Shortcut “Q”), Move 

(Shortcut “W”), scale (Shortcut “E”), and Rotate 
(Shortcut “R”) tools to build a basic lumen 
shape.

•	Adaptive Skin > Preview
•	Click “Make Adaptive Skin”
•	Subtool > Append > Select “Skin_ZSphere_1”
•	Re-select Zsphere subtool
•	Adaptive Skin > Click preview (turns preview off)
•	Hide ZSphere and Skin_ZSphere for now.
Creating Salivary Cell InsertMesh
•	Subtool > Append > Sphere
•	Select new Sphere subtool
•	Deformation > Taper (X, Z dimensions)
•	Deformation > Squeeze (Y dimension)
•	Geometry > ZRemesher > Use ZRemesher 

with either “Half” selected or with 
Adaptive size set to 4 or below until you 
achieve a mesh with fewer than 500 
polygons.

•	Hold Shift and rotate your view until the view 
snaps to looking directly at the wide end/
bottom of your initial salivary cell.

•	Brush > Create InsertMesh
•	Select “NEW” in pop up dialogue
•	Creates a new InsertMesh brush from the 

current Mesh.
•	Select and make visible Skin_ZSphere
•	Geometry > Sdiv > Set to 1
•	Click “Del higher”.
Arrange Cells Around Lumen
•	Brush > InsertMesh (your new brush will be 

in the top “Quick Pick” row).
•	Click and drag on the Skin_ZSphere 

surface to “draw” on salivary cells. 
Proportions get skewy? Hit command to 
reset the proportions of the mesh you are 
currently drawing.

•	Keep drawing the cells on until you get 
the approximate distribution that 
you would like. (It’s ok if they overlap, 
especially if you can use the Cinema4D 
soft bodies technique described below).

•	Polygroups > autogroups (makes each cell 
a separate group)

Manually Adjusting Cell Fit
•	Hold Cmd-Alt-Shift and click a cell/polygroup that you would 

like to hide. Click again (the first click will isolate it, the 
second click will hide it). Continue clicking groups that you 
would like to remove.

•	Select the Move Topological Brush (Shortcut B, M, T).
•	Scale the Move Topological Brush up.
•	Begin squeezing the neighboring cells aside.
•	Continue hiding and squeezing, and sculpting until you are 

happy with the fit.

Dynamically Adjusting Cell Fit in Cinema4D
Export your preliminary model
•	Confirm that all the cells in your model are separate 

polygroups (if not, Polygroups > Autogroups)
•	With Skin_Zphere1_1 subtool selected

•	 Tool > Export 
•	 Save your .obj 

Import model to Cinema4D
•	Open Cinema 4D
•	File > Merge > Select your .obj

Confirm that the size of your object is reasonable (at least a 
few cm in each dimension). Otherwise dynamics will glitch.

•	If it is too small, delete and reimport. Modify the Scale option 
in the OBJ Import Window. (ex from 1 to 10)

Because all of your cells were separate polygroups in ZBrush, 
they’re now separate objects in C4D.

•	Select and rename your lumen object. 
•	Group all of your cells together in a new null.
•	Select all of your cell objects 

(not the null).
•	Mesh > Axis  > Center Axis To
Setting Up Dynamics
•	Edit > Project Settings (or Cmd-D) > Dynamics Tab > Set 

Gravity to 0
•	Select Cell Null
•	Tags > Simulation Tags > Rigid Body
•	Rigid Body Tag Settings:

•	 Collision Tab:
•	 Inherit Tag: Apply Tag to Children
•	 Individual Elements: All
•	 Size Increment: 1 (Depends on the original size of 

your import - adjust as needed)
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This makes breathing room around your cell objects. 
(Otherwise they will be overlapping when you switch to soft 
body simulation, and will promptly explode)

•	 Force Tab:
•	 Linear Damping: 100
•	 Angular Damping: 100

•	Hit play. This will cause the cells to stop overlapping, while 
the linear and angular damping keeps 
them from flying off. 

•	Once the cells are spread apart, delete 
the Rigid body tag (without returning 
the playhead to 0). This will make this 
new position their initial position. 

•	Return playhead to 0.
•	Make lumen a collider body

•	 Select lumen
•	 Tags > Simulation Tags > Collider 

body
•	Add a soft body tag to your cell null.

•	 Select Cell Null
•	 Tags > Simulation Tags > Soft 

Body
•	Soft Body Tag Settings

•	 Collision Tab
•	 Inherit Tag: Apply Tag to 

Children
•	 Use - checked
•	 Margin 0.01 cm
•	 Bounce 0
•	 Friction 300

•	 Soft Body Tab
•	 Shape Conservation 
•	 Stiffness 10
•	 Damping 200%

Make an attractor to draw soft body cells to lumen.
•	Simulate > Particles > Attractor

•	 Strength: 100
•	 Speed limit: 20

•	Click play. The cells should move in 
toward the lumen, and squish 
together as they all try to reach the 
attractor at the center.

•	You may need multiple attractors so 
the cells are attracted along length 
of lumen instead of to one point.
•	 Group each set of cells that you 

want attracted to each region 
of the lumen.

•	 Give each group a copy of your soft body tag. 
•	 Soft Body Tag Settings > Force Tab:

•	 Force Mode: Include
•	 Force List: Drag and drop the appropriate attractor 

in here
•	Click Play. Your cells will squish together. Pause the animation 

when you are happy with the result. It won’t be perfect 
here, and you will still need to manually adjust in ZBrush, 
but this will get the majority of the work done for you.

•	Once the animation plays to a point where you are satisfied 
with the deformation, delete your soft body tags. 

•	File > Export > Wavefront (.obj)

ReImport to ZBrush
•	Open ZBrush
•	Load your previous tool.
•	Append a new subtool of any kind.
•	With new subtool selected, import your squished cell .obj
•	Tool > Import

Your import may be very large relative to your original ZBrush 
model. Use either the Scale tool or Deformation > Size to 
shrink your imported subtool to the appropriate size.

•	PolyGroup > AutoGroup
•	Hide all cell polygroups, leaving just lumen.
•	Duplicate ZSphere lumen
•	Line up Zsphere copy to match the lumen of your import, if it 

has moved askew.
Manual Touch Up
•	You may still want to make a few manual adjustments to the 

cells. For this, use your sculpting brushes, including Move 
Topological, and subdivide your geometry as necessary.

ZSketch Lumen Shape
•	Hide one of your salivary cells 

so you can see the sides of 
the cells around it and the 
lumen.

•	Ctrl/Cmd-Alt-Shift + Click cell 
twice (first click will isolate, 
second click will hide)

•	Select your duplicate Zsphere 
lumen that you aligned 
to your updated model’s 
lumen.

•	ZSketch > Edit Sketch
•	Sketch in your intercellular 

canaliculi
•	Switch back to your cells. Hide 

another cell.
•	Ctrl/Cmd-Alt-Shift + Click cell once.
•	Sketch in the intercellular canaliculi bordering the hidden 

cell.
•	Continue ZSketching until you have a lumen and intercellular 

canaliculi shape that you are satisfied with.

Turn ZSpheres into Geometry
•	Unified Skin > Preview
•	Adjust SDiv, Resolution, Smooth, and Polish 

parameters until you’re happy with the 
resulting geometry.

•	Click [Make Unified Skin]
•	Turn the Unified Skin off

•	 Unified Skin > Click [Preview]
•	Subtool > Append > Select “skin_

yourZSphereModelName”
•	Make sure your original Zsphere Model is 

still selected. 
•	Turn off ZSketch
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•	ZSketch > Click [EditSketch]
This will leave only your underlying ZSphere rigging.

•	Adaptive Skin > Preview
•	Adjust Adaptive Skin Density parameter until you’re happy 

with the geometry
•	Click [Make Adaptive Skin]
•	Turn the Adaptive Skin off

•	 Adaptive Skin  > Click [Preview]
•	Subtool > Append > Select skin_yourZSphereModelLumen
•	Merge your canaliculi and lumen skin models in the SubTool 

palette
•	 Make sure one is on top of the other in the SubTool 

order
•	 Select the top skin.

NanoMesh: Model a blastula
Create InsertMesh brush
•	Create a cell model (we’ll use our original cell from our 

salivary acinus project)
•	Hold Shift and rotate your view until the view snaps to 

looking directly at the wide end/bottom of your cell model
•	Brush > Create InsertMesh
•	Select “NEW” in pop up dialogue
•	Creates a new InsertMesh brush from the 

current Mesh.
Apply InsertMesh as NanoMesh
•	Append a sphere object.
•	Retopologize with ZRemesher until it as 

as many polys as you want cells in your 
blastula

•	Select your cell InsertMesh brush.
•	Brush > Create NanoMesh brush
•	Click and drag on one of your sphere’s 

polys. This creates a single nanomesh. 
•	However, we want an instance of our cell 

model on each polygon.
•	Hover the brush over a polygon and hold 

spacebar
•	Select Target > All Polygons from the 

resulting menu
•	Click and drag on any polygon on your 

sphere
•	As you drag, an instance of the cell will 

expand on each polygon.
•	To refine your cells and make them a bit 

more organic, open the NanoMesh 
palette

•	Adjust WVar, LVar, and HVar to get a more 
organic variation to your cells

Make your NanoMesh to a Subtool
•	NanoMesh > Inventory > Click [One To 

Mesh]
•	If you would like your NanoMesh cells 

and original sphere as separate 
subtools, in the SubTool palette select 
Split >  Groups Split

This model 
was used for 
Cinema4D 
rendering 
(1) and as a 
maquette 
for the 
salivary 
gland cross 
section (2) 
in A Spitting 
Image in 
3D, which is 
currently on 
display in 
the Salon.

1

2

•	 Click [MergeDown]
•	If you created your skin with 

subdivisions, delete the lower ones.
•	Geometry > [Del Lower]
•	Dynamesh to merge the geometry. 

Adjust DynaMesh parameters if 
necessary.

•	Use ZRemesher to create a render & 
animation friendly topology. Adjust 
parameters as necessary

Now you have a salivary acinus with 
nicely squished together cells and a model 
for the intercellular canaliculi and lumen!

FiberMesh: Model a Neuron
•	Build a base model using ZSpheres.
Turn you ZSphere base neuron into a sculptable mesh
•	Adaptive Skin > Click [Preview]
•	Adjust Adaptive Skin Density parameter until you’re happy 

with the geometry
•	Click [Make Adaptive Skin]
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•	Turn the Adaptive Skin off
•	 Adaptive Skin  > Click [Preview]

•	Subtool > Append > Select skin_yourZSphereNeuron
•	Use the smooth brush if necessary to taper your model’s axon 

and branches. 
Make a dendrite insert mesh
•	Append a Zsphere
•	Build a dendrite base model using 

ZSpheres
•	Adaptive Skin > Preview

•	 Adjust Adaptive Skin 
Density parameter until 
you’re happy with the 
geometry

•	Click [Make Adaptive Skin]
•	Turn the Adaptive Skin off

•	 Adaptive Skin  > Click 
[Preview]

•	Subtool > Append > Select skin_
yourZSphereDendrite

•	Use the smooth brush if necessary 
to taper your dendrite mesh

•	Rotate your view until you are looking 
down the long axis of the dendrite 
from the tip

•	Brush > Create InsertMesh
•	Select “NEW” in pop up dialogue

Creates a new InsertMesh brush from the 
current Mesh.

•	Select your Neuron Mesh
•	Brush > Depth > Decrese Imbed value

This will ensure the root of your dendrite 
inserts into neuron mesh

•	Use the dendrite InsertBrush to insert 
dendrites into cell body base

•	Once you have finished applying 
dendrites to the model, clear the mask and turn on 
PolyGroup view. Each dendrite is a different polygroup.

•	Dynamesh to create a unified Mesh.
•	Mask the tips of the axons and dendrites

FiberMesh nerve branchings
•	Apply a default fiber pre-set
•	FiberMesh > Lightbox Fibers 

> FiberMesh132
This will look ridiculous, but 
we’ll adjust in the FiberMesh 
Modifiers

FiberMesh Modifiers
•	 MaxFibers: 0.08
•	 Imbed: 0.2
•	 ByMask: 5 (max)
•	 Length: 600
•	 LeV: 0.5
•	 Width profile > Expand > 

Reset 
•	 Adjust curve so fibers 

are thicker at base
•	 Coverage: 500
•	 Revolve Radius > Expand 

> Reset
•	 Revolve Rate: 10
•	 Base Color: White
•	 Tip Color: White
•	 Texture: turn off

Turning fibers into geometry
•	Adjust profile and segments to the full resolution that you 

would like
•	Click [Accept].
•	Your Fibers are now a new subtool, and can be adjusted with 

both regular brushes and groom brushes.

Custom Alphas: Tumor Texture
Create your custom texture
•	In Photoshop, create a 1000 x 1000 

pixel file with the texture of your 
choice, and vignette it to black 
around the edges:

•	Save as TextureName.psd
NCI Visuals Online is a good source 
of public domain research images 
(micrographs, pathology photos, etc.) 
that may be helpful to derive a texture 
from.

•	In ZBrush, create or load the model 
you want to texture.

Set up your custom alpha brush
•	Brush > Dam_Standard
•	Stroke > Drag Rectangle
•	BrushAlpha > Import > Select 

TextureName.psd
•	Click and drag to apply the texture 

to your model. Adjust the brush’s 
Z-intensity and the model subdivisions as needed.

Final touch
•	Masking > Mask by AO > Click [Mask Ambient Occlusion]
•	Deformation > Inflate balloon

This will take your textured object from moon rock to squishy, 
gross tumor. 


